Swirling flow

Cisco Router Configuration

Below in an example of Cisco's command line configuration for their family of Cisco Routers covering the 800, 1700, 1800, 2600, 3600 & 7200 routers.

The following Cisco Router Configuration is only for reference use only and is not intended to be utilised for live configurations. Configuring a router or PIX firewall incorrectly can often cause more damage than not having any protection at all. 

Cisco Router Configuration

no service pad
service timestamps debug datetime msec
service timestamps log uptime
service password-encryption
!
hostname customerrouter
!
logging buffered 9999 debugging
no logging console
no logging monitor
enable secret secret
!
username admin password secret
no aaa new-model
ip subnet-zero
no ip domain lookup
ip domain name customerdomain
!
!
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface fastethernet0
ip address 192.168.1.254
ip proxy-arp
no ip split-horizon
fair-queue
no cdp enable
hold-queue 100 out
!
interface atm0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
!
interface Dialer1
description Connection to ADSL
ip address 195.12.1.6 255.255.255.248
no ip proxy-arp
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname
ppp chap password
ppp pap sent-username password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
ip http authentication local
no ip http secure-server
!
access-list 10 permit 192.168.1.0 255.255.255.0
no cdp run
!
line con 0
password secret
logging synchronous
no modem enable
line aux 0
line vty 0 4
access-class 10 in
password secret
login
!
scheduler max-task-time 5000
!
end